3. Tlačítkem Změnit zobrazte okno pro zadání nadpisu vytvářené stránky. 4. Volbou Znovu automaticky publikovat při každém uložení tohoto sešitu vytvoříte propojení mezi webovou stránkou a zdrojovým sešitem. Při uložení změn v sešitu se webová stránka aktualizuje. 5. Při označení volby Otevřít publikovanou stránku v prohlížeči se po exportu spustí webový prohlížeč a do něj se načte vytvořená stránka. 6. Tlačítkem Procházet můžete změnit umístění vytvářeného souboru. 7. Po výběru voleb klepněte na tlačítko Publikovat.
Obrázek 3.62: Publikování webové stránky
3.5 Práce se soubory XML 3.5.1 Struktura souborů XML a jejich využití v Excelu
Soubory typu XML jsou textové soubory vytvořené v přesně stanoveném formátu, které umožňují výměnu dat mezi různými typy programů. Využívají se zejména v souvislosti s in ternetovými aplikacemi. Soubor XML se skládá z hlavičky, obsahující zejména údaj o kódo vání češtiny, a série párových značek (tagů), které uzavírají vložená data. Počátek a konec tagu se rozpozná podle stejného názvu, u koncové značky je navíc před názvem zapsáno lomítko.
Obrázek 3.63: Struktura souboru XML
98 Excel 2013 – práce s databázemi a kontingenčními tabulkami
Ukázka elektronické knihy, UID: KOS198618
V souborech XML se používá především dvojí kódování češtiny: zz Windows 1250 – kódování používané v programech kompletu MS Office. zz UTF-8 – kódování používané při tvorbě webových stránek. Jednoduchý soubor XML, který svou strukturou odpovídá dvourozměrné tabulce, má tři úrovně tagů: nejvyšší úroveň představuje tabulku jako takovou, druhá úroveň řádky a třetí úroveň tagů jednotlivé sloupce. Tagy je však možné vkládat do sebe a vytvářet tak strukturu, členěnou do mnoha úrovní. Převáděné informace mohou být zapsány i přímo ve značce tagu jako parametry; tag tohoto typu tvoří samostatnou informaci bez koncové značky. K souborům XML se složitou strukturou může být přidružen soubor s příponou XSD, obsa hující informace o struktuře tagů.
Před importem dat ze souboru XML do Excelu na soubor XML poklepejte. Tím spustíte internetový prohlížeč, který soubor XML zobrazí. Bezchybný soubor XML se v okně prohlížeče zobrazí celý a import se provede správně. Jestliže se v okně prohlížeče objeví zpráva o chybě, soubor XML není správně zapsán nebo chybí potřebný soubor XSD a import do Excelu selže. Import dat ze souboru XML do Excelu můžete provést dvojím způsobem: zz importem, zz přímým otevřením souboru XML.
Obrázek 3.64: Zobrazení karty Vývojář
Práce s externími daty 99
Ukázka elektronické knihy, UID: KOS198618
Pro práci s importovanými soubory typu XML je zapotřebí zobrazit kartu Vývojář. Pokud není v Excelu zobrazena, postupujte takto: 1. Klepněte na kartu Soubor. 2. Vpravo dole klepněte na příkaz Možnosti. Tímto příkazem zobrazíte okno pro nastavení Excelu 2013. 3. V levé části okna označte sekci Přizpůsobit pás karet. 4. V pravém seznamu označte volbu Vývojář a potvrďte tlačítkem OK. Toto nastavení Excelu je trvalé.
Obrázek 3.65: Karta Vývojář
3.5.2 Import dat ze souboru XML
Importování dat ze souboru XML do sešitu Excelu proveďte takto: 1. Na kartě Data stiskněte tlačítko Z jiných zdrojů a použijte volbu Z importu dat XML. 2. Druhou možností je přejít na kartu Vývojář a v sekci XML klepnout na tlačítko Import. 3. V zobrazeném dialogovém okně pro ote vření souboru nalezněte umístění a ná zev importovaného souboru XML (typ souboru se nastaví automaticky). 4. Stiskněte tlačítko Otevřít. Pokud se zob Obrázek 3.66: Upozornění při importu souboru XML razí upozornění, klepněte na tlačítko OK a pokračujte dále. 5. V dalším zobrazeném okně můžete zvolit buňku na aktiv ním listu, kam se importovaná tabulka vloží, nebo ji vložit na jiný list. 6. Import potvrďte tlačítkem OK. Výsledkem importu je formátovaná tabulka. Můžete v ní vy užívat všechny popsané možnosti formátované tabulky včet ně exportu do programu MS Visio. Při importu souboru XML nezáleží na kódování češtiny, pro obě verze (Windows 1250 Obrázek 3.67: Umístění importova né tabulky a UTF-8) se čeština převede správně.
Jestliže soubor XML obsahuje jediný tag druhé úrovně čili jedinou řádku, do sešitu se přenesou data, ale nevytvoří se hlavička a data se zapíšou na první řádek. Data na listu nemají charakter formátované tabulky. Jednotlivé sloupce v tabulce odpovídají tagům ve třetí a dalších úrovních. Tag s parametry vytvoří v tabulce další sloupce, odpovídající jednotlivým parametrům. Jestliže se v souboru XML opakuje několik stejných tagů nižší úrovně s různými hodnotami, vytvoří se více řádků a údaje, odpovídající tagům vyšších úrovní, se opakují. 100 Excel 2013 – práce s databázemi a kontingenčními tabulkami
Ukázka elektronické knihy, UID: KOS198618